[Service update] Migrating to new Hexaple Status

Incident Report for Hexaple

Update

We apologize for any inconvenience that may have caused. If you have any questions or concerns, please contact HexaHelp for assistance.
Posted Apr 18, 2024 - 20:02 PDT

Investigating

Starting from June 1, we are upgrading to the next generation Hexaple Status that provides real-time updates on Hexaple online applications and services. The current Hexaple Status will be active until the date of migration. Please bookmark the URL for the new status page: https://stats.uptimerobot.com/zoXKUsUWzS
Posted Apr 18, 2024 - 19:58 PDT